Friday, November 6, 2020

Page Inspection Keyboard Shortcut CTRL+ALT+F1 Doesn't Work on Laptop

By Steve Endow


Update: I originally wrote this post referencing my Lenovo ThinkPad P1 laptop, but it appears that similar Intel Graphics software is used on several different laptop brands and models, causing the same issue.  The name or appearance of the specific Intel Graphics software may vary, but the concept still applies.


If you use Dynamics 365 Business Central, you should be aware of the Page Inspection feature.

Inspect my page

https://docs.microsoft.com/en-us/dynamics365/business-central/across-inspect-page

One of the ways to open the Page Inspection pane while viewing a Business Central page in a browser is to press the keyboard shortcut CTRL + ALT + F1.

Handy Keyboard Shorcut


While doing some BC development and testing on my new Lenovo ThinkPad P1 laptop, I pressed CTRL + ALT + F1 to open Page Inspection.

But nothing happened.

I pressed the shortcut again.  And again.  Nothing.  Kind of like the crosswalk button or the elevator door close button.

I then opened Business Central on my desktop computer and pressed the shortcut.  Worked fine, and the Page Inspection pane opened.

Huh.  

I double checked the individual keys on my ThinkPad actually worked. I then tested if the CTRL + ALT + F1 shortcut could be detected by a local Windows app, and that shortcut could NOT be captured.  CTRL + ALT + F2 worked fine, but not F1.

So for some reason, CTRL + ALT + F1 didn't work on my ThinkPad.

After a quick Google search, I found I wasn't alone.  Other ThinkPad users have had issues with CTRL + ALT + F Key shortcuts.  It seems that the issue is sometimes caused by factory installed configuration software.

My laptop has a program called Intel Graphics Command Center.  No idea what it does or why I would ever use it--I'm assuming it gets installed with the graphics card drivers.

Useless to me

And it turns out that annoying program has a default shortcut key of, you guessed it, CTRL+ALT+F1.

Summer Interns At Intel

Even though the "Enable System HotKeys" setting is turned OFF in the Graphics Command Center software, the software still registers the shortcut key with Windows, preventing any other apps from using it.  And unfortunately, you can't set the shortcuts to "None"--you have to choose a valid CTRL+ALT or CTRL+SHIFT shortcut.

Lovely.

The solution is to enable hotkeys in the application, then change the CTRL+ALT+F1 default shortcut to something else, and then turn off the hotkeys setting.

After making this change, the CTRL+ALT+F1 shortcut started working for me in the Business Central page in my browser.

And this is just one more example of why I can't get any work done... 


Steve Endow is a Microsoft MVP in Los Angeles.  He works with Dynamics 365 Business Central, Microsoft Power Automate, Power Apps, Azure, .NET, Dynamics GP, and SQL Server.

You can also find him on Twitter and YouTube

https://www.precipioservices.com

No comments:

Post a Comment

All comments must be reviewed and approved before being published. Your comment will not appear immediately.

Page Inspection Keyboard Shortcut CTRL+ALT+F1 Doesn't Work on Laptop

By Steve Endow Update: I originally wrote this post referencing my Lenovo ThinkPad P1 laptop, but it appears that similar Intel Graphics sof...